S3 issues again Thursday 2nd October 2025 14:14:00


Update 3rd of October 11:20:00: All services are back to normal. We are in touch with our provider about how to solve this issue for good.


Update 14:40 CEST: We're sending emails again but we're not storing HTML and text content or attachments. We'll update when this changes.


Once again our hosting provider has issues with S3 hosting. We are making changes in order to handle the issue but mail queues should be up and running again soon. New update in 20 minutes.